Back to overview
Maintenance
Better Mailing UI
Dec 20 at 01:20am HST
–
Dec 20 at 01:30am HST
Affected services
API 1
Resolved
Dec 20 at 01:20am HST
API under maintenance for updating the Email UI
Affected services
Resolved
Dec 20 at 01:20am HST
API under maintenance for updating the Email UI
Affected services